Web sayfamız sadece phpBB 3.0.x sürümlerine destek vermektedir. Konu açmadan, ileti yazmadan önce lütfen site kuralları sayfamıza göz atınız.


phpBB 3.0.8 duyuruldu

phpBB 3.0.8 duyuruldu

İleti ALEXIS 21 Kas 2010 02:42

phpBB Grubu, phpBB 3.0.8 sürümünü duyurdu. Bu yeni sürüm, çok sayıda hatanın giderildiği, kullanılabilirlik ve performans iyileştirmelerinin yapıldığı bir genel sürümdür.

phpBB Grubu, önceki sürümde flash BBCode açıldığında ortaya çıkan bir güvenlik sorunu keşfetmiş (flash BBcode varsayılan olarak kapalı gelmekte).

Safari, Chrome gibi WebKit tabanlı web tarayıcıları yanı sıra Opera web tarayıcısında flash BBCode kullanılarak javascript çalıştırma ile "çapraz site betik saldırısı" (cross site scripting) güvenlik açığına neden olabilen bir güvenlik sorunu.


3.0.7 sürümünde bu hatayı gidermek için, includes/message_parser.php dosyasında, satır 354 civarında şu kodu bulun:

Kod: Tümünü seç
      // Apply the same size checks on flash files as on images


Bu kodun hemen öncesine / üzerine şu kodu ekleyin

Kod: Tümünü seç
      // + phpBB 3.0.8 ile gelen flash BBcode yaması
      $in = str_replace(' ', '%20', $in);

      // Make sure $in is a URL.
      if (!preg_match('#^' . get_preg_expression('url') . '$#i', $in) && !preg_match('#^' . get_preg_expression('www_url') . '$#i', $in))
      {
         return '[flash=' . $width . ',' . $height . ']' . $in . '[/flash]';
      }
      // - phpBB 3.0.8 ile gelen flash BBcode yaması


Bu yama mevcut - önceden yazılan iletileri etkilemektedir. Mesaj panonuzdaki kötü niyetli iletileri tespit amacıyla phpBB Grubu bir tarama betiği oluşturmuş. Basitçe betiği phpBB kök dizinine yükleyin ve direk olarak tarayıcınız ile erişin. Yeni sürüm "Destek Aracı" (Support Toolkit) bu tarama betiğini de içerecektir.

Sürüm aynı zamanda spam göndericilerin bazı durumlarda recaptcha eklentisini atlatmalarını engellemek için yamalar içermektedir.

phpBB Grubu, mümkün olduğunca çabuk sürüm güncellememizi öneriyor. phpBB Grubu, yardım takımı sadece phpBB 3.0.8, phpBB 3.0.8'e güncelleme ve phpBB 3.0.8'e dönüştürme konularına yardımcı olacakmış. Aşırı ağır olmasa da phpBB Türkiye olarak biz de eski sürümleri terk edip sadece phpBB 3.0.8 desteği vermek isteriz.

3.0.7-PL1 sürümünden sonra yapılan değişiklikleri tam listesi:
http://www.phpbb.com/support/documents. ... 3#v307-pl1

phpBB 3.0.8 dosyaları



Yardımcı bilgiler
ALEXIS
yönetici
yönetici

Kullanıcı avatarı

İleti: 3628
Kayıt: 03 Arl 2006 08:57
HTML: Çok iyi
CSS: İyi
PHP: İyi
phpBB3: Çok iyi
Sürüm: phpBB 3

 

Duyuru & Haberler


Kimler çevrimiçi

Bu forumu görüntüleyenler: Kayıtlı kullanıcı yok ve 0 misafir

cron