Web sayfamız sadece phpBB 3.0.x sürümlerine destek vermektedir. Konu açmadan, ileti yazmadan önce lütfen site kuralları sayfamıza göz atınız.


Bazı ekentilerde soru işareti problemi?

Bazı ekentilerde soru işareti problemi?

İleti korayaksu61 01 Şub 2017 21:53

Merhaba arkadaşlar;

Sizden bir ricam olacak. Ben bazı kulladığım phpbb eklentierde bazı sorunlar yaşıyorum. Kullandığım bazı eklentilerde yönetim kontrol panelindeki bir eklentide textbox kutusunun içerisini bazı Türkçe karakterler örneğin; ç,ş,ı,ü,ö gibi bu tür harfler girdiğimde 'Gönder' butonuna tıklattığım zaman ilgili eklentinin sayfasında bahsettiğim karakterler '?' soru işareti olarak gözüküyor. Bunun bir çözüm yolu var mı? Sorunu çözmek için ne yapmalıyım. Bana bu konuda yardım eder misiniz? Ben internette biraz araştırma yaptım ama hiç biri fayda etmedi. Phpbb sisteminde bu sorunu aşabiliriz, lütfen bana bu konuda yardımcı olur musunuz? :|
korayaksu61
kullanıcı
kullanıcı

İleti: 54
Kayıt: 06 Nis 2011 22:13
Konum: İstanbul
İsim: Koray Aksu
HTML: Çok iyi
CSS: Çok iyi
PHP: Orta
phpBB3: Çok iyi
Sürüm: phpBB 3.2.4

 

Re: Bazı ekentilerde soru işareti problemi?

İleti Simuzer 21 Şub 2017 14:40

ilgili eklentinin veritabanı tablosundaki karakter kodunda problem olabilir. phpmyadmin.den bakıp kontrol edilmesi gerek. Diğerleriyle benzer olmalı. (utf8_bin gibi)
Simuzer
kullanıcı
kullanıcı

Kullanıcı avatarı

İleti: 1127
Kayıt: 28 Mar 2007 20:19
HTML: İyi
CSS: Orta
PHP: Başlangıç
phpBB3: Orta
Sürüm: 3.0.5

Re: Bazı ekentilerde soru işareti problemi?

İleti korayaksu61 26 Şub 2017 21:20

Ben sorunun nereden kaynaklandığını buldum arkadaşlar? Böyle eklentilerde bu tür sorunla karşılaştığınız zaman Türkçe karakterleri '?' soru işareti olarak gösteren ilgili eklentinin PHP dosyasını düzenlemeniz gerekiyor. Yapmanız gereken çok küçük bir kod eklemesi yapmanız gerekiyor. Aşağıdaki örnek gibi;

Aşağıdakine benzer PHP kodu;

:!:
Kod: Tümünü seç
$degisken_adi   = request_var('degisken_adi', '');


Bu şekilde değiştirmek gerekiyor:

:arrow:
Kod: Tümünü seç
$degisken_adi   = request_var('degisken_adi', '', true);


Genede yardım için teşekkürler Simuzer arkadaşım. phpmyadmin'e baktım ilgili eklentinin veritabanı tablosundaki karakter kodu utf8_bin olarak görünüyor. :)
korayaksu61
kullanıcı
kullanıcı

İleti: 54
Kayıt: 06 Nis 2011 22:13
Konum: İstanbul
İsim: Koray Aksu
HTML: Çok iyi
CSS: Çok iyi
PHP: Orta
phpBB3: Çok iyi
Sürüm: phpBB 3.2.4

Re: Bazı ekentilerde soru işareti problemi?

İleti CitLemBiK 19 Mar 2018 15:07

utf8_unicode_ci candir ama. :)
CitLemBiK
genel yetkili
genel yetkili

Kullanıcı avatarı

İleti: 1138
Kayıt: 23 Oca 2008 12:27
Konum: Söylemem
İsim: Isim Siz
HTML: Orta
CSS: Başlangıç
PHP: Orta
phpBB3: İyi
Sürüm: phpBB 3.0.6 (Branch)

Re: Bazı ekentilerde soru işareti problemi?

İleti Simuzer 20 Nis 2018 15:26

CitLemBiK yazdı:utf8_unicode_ci candir ama. :)


Öyle ama cana da can katmak gerekir :mrgreen:
Simuzer
kullanıcı
kullanıcı

Kullanıcı avatarı

İleti: 1127
Kayıt: 28 Mar 2007 20:19
HTML: İyi
CSS: Orta
PHP: Başlangıç
phpBB3: Orta
Sürüm: 3.0.5


Eklenti Sorunlar & Yardım


Kimler çevrimiçi

Bu forumu görüntüleyenler: Kayıtlı kullanıcı yok ve 1 misafir

cron