Web sayfamız sadece phpBB 3.0.x sürümlerine destek vermektedir. Konu açmadan, ileti yazmadan önce lütfen site kuralları sayfamıza göz atınız.

internet explorer 6 kullananları uyarmak

internet explorer 6 kullananları uyarmak

İleti standartt 27 Haz 2009 12:18

internet explorer altı veya başka bir tarayıcıdan gelen kullanıcılara özel bir mesaj hazırlayabiliriz elbette.
yaptığımız düzenlemeler sonucunda çoğumuz css yi çok iyi bilmediğimiz için eski tarayıcılarda sorunlarla karşılaşabiliyoruz. ayrıca ie6 çok eski bir tarayıcı ve geliştirilmesi durduruldu.

ben kodlardan çok anlamıyorum ama aşağıda yazdığım gibi bir uyarı kodunu yazabilecek arkadaşlara şimdiden teşekkür ediyorum.

Kullanmakta olduğunuz internet tarayıcısı bu sayfayı düzgün görüntüleyemiyor. En iyi görüntüye ulaşabilmek
için lütfen tarayıcınızı değiştirin gibi.

tabi taraycıya gire değişecek bir kod.
standartt
kullanıcı
kullanıcı

İleti: 132
Kayıt: 16 Oca 2009 01:27
Konum: Çorum
İsim: Rıfat ÜÇÜNCÜ
HTML: İyi
CSS: Başlangıç
PHP: Başlangıç
phpBB3: Orta
Sürüm: phpBB3 3.0.7 PL1

Re: internet explorer 6 kullananları uyarmak

İleti EsmerOzcan 27 Haz 2009 16:39

Kendi yazdigim Modu baska siteye tanitmistim onu alinti yaptim belki isini görür...

Mod Yazar: EsmerÖzcan
Mod sürüm: 0.0.2
Mod Aciklamasi:

Internet Explorer 6 Kullanicilara Forumunuzun tüm Sayfalarinda Uyari verir ya IE 7 ye yada Mozilla Firefox kullanmalari icin bu sadece IE 6 Kullanicilara gözükür simdilik tek prosilver tabanli temalar icin yaptim bi kac güne subsilver2 icinde yaparim...

Resimler:

Resim
Resim


Kurulum:

Ac: styles/prosilver/template/overall_header.html


BUL

Kod: Tümünü seç
      <div class="navbar">



Öncesine Ekle

Kod: Tümünü seç
<!--[if lte IE 6]>            
    <div class="navbar">
        <div class="inner">
      <span class="corners-top"><span></span></span>
    <ul class="linklist">
    <h4><font color="#BF0000">Internet Explorer 6 Uyarisi</font></h4><hr />
    <li>
    Merhaba Ziyaretçi Su anda <font color="#BF0000"><b>Internet Explorer 6</b></font> Veya Daha Eski Bir Versiyon Kullaniyorsunuz.
    Kullandiginiz Internet Tarayicisi Bu Sayfada Kullanilan Bir Çok Özelligi Desteklemiyor ve Sayfada kullanilan Resimleri, Grafikleri Kalitesiz ve Eksik Gösteriyor Kullandiginiz Tarayiciyi <a href="http://www.microsoft.com/turkiye/windows/ie/default.mspx"><font color="#BF0000"><b>Internet Explorer 7</b></font></a> Versiyonuna Yükseltmeniz Yada Daha Gelismis Olan <a href="http://www.mozilla-europe.org/tr/products/firefox/"><font color="#BF0000"><b>Mozilla Firefox</b></font></a> Yüklemenizi Öneririm!
    </li>
    </ul>
         <span class="corners-bottom"><span></span></span>
       </div></div><br clear "all" />
<![endif]-->   


Subsilver2 icin

Kod: Tümünü seç
   <!-- INCLUDE breadcrumbs.html -->

   <br />



Sonrasina Ekle

Kod: Tümünü seç
<!--[if lte IE 6]>      
<table cellSpacing="1" cellPadding="0" width="100%" align="center" border="0" class="forumline">
<td class="cat" colspan="2"><center><h4><font color="#BF0000">Internet Explorer 6 Uyarisi</font></h4></center></td></table>
<table class="tablebg" width="100%" cellspacing="1">
<tr>
<td class="row1" align="center" colspan="2">
    Merhaba Ziyaretçi Su anda <font color="#BF0000"><b>Internet Explorer 6</b></font> Veya Daha Eski Bir Versiyon Kullaniyorsunuz.
    Kullandiginiz Internet Tarayicisi Bu Sayfada Kullanilan Bir Çok Özelligi Desteklemiyor ve Sayfada kullanilan Resimleri, Grafikleri Kalitesiz ve Eksik Gösteriyor Kullandiginiz Tarayiciyi <a href="http://www.microsoft.com/turkiye/windows/ie/default.mspx"><font color="#BF0000"><b>Internet Explorer 7</b></font></a> Versiyonuna Yükseltmeniz Yada Daha Gelismis Olan <a href="http://www.mozilla-europe.org/tr/products/firefox/"><font color="#BF0000"><b>Mozilla Firefox</b></font></a> Yüklemenizi Öneririm!
</td>      
      </tr>
</table><br clear "all" />
<![endif]-->
EsmerOzcan
kullanıcı
kullanıcı

İleti: 101
Kayıt: 27 Tem 2008 02:35
Konum: Nürnberg
İsim: Özcan Akbulut
HTML: Çok iyi
CSS: Çok iyi
PHP: Çok iyi
phpBB3: Çok iyi
Sürüm: phpBB 3.1.1

Re: internet explorer 6 kullananları uyarmak

İleti standartt 27 Haz 2009 20:26

denemedim ama kodlarından belli zaten düzgün çalışacağı. ellerine sağlık. teşekkürler.
standartt
kullanıcı
kullanıcı

İleti: 132
Kayıt: 16 Oca 2009 01:27
Konum: Çorum
İsim: Rıfat ÜÇÜNCÜ
HTML: İyi
CSS: Başlangıç
PHP: Başlangıç
phpBB3: Orta
Sürüm: phpBB3 3.0.7 PL1

Re: internet explorer 6 kullananları uyarmak

İleti standartt 29 Haz 2009 00:44

ben burada ayrıca birşey sormak istiyorum.

<!--[if lte IE 6]> deyimini kullanmışsın. ve uyarı içerisinde internet explorer altı veya daha eski versiyon kullanıyorsunuz demişsin.

ben kodlardan pek anlamam ama bu if deyimi içerisindekiler explorer altı ve daha kullanan olmasada yinede explorer 5 için çalışırm mı?

lte ne anlama geliyor?
standartt
kullanıcı
kullanıcı

İleti: 132
Kayıt: 16 Oca 2009 01:27
Konum: Çorum
İsim: Rıfat ÜÇÜNCÜ
HTML: İyi
CSS: Başlangıç
PHP: Başlangıç
phpBB3: Orta
Sürüm: phpBB3 3.0.7 PL1

Re: internet explorer 6 kullananları uyarmak

İleti EsmerOzcan 29 Haz 2009 01:25

bu herseyi aciklar sanirim :)

akansu yazdı:
<!--[if IE 6]> yerine <!--[if lte IE 6]> şeklinde kullanırsak "Şu anda İnternet Explorer 6 Veya Daha Eski Bir Versiyon Kullanıyorsunuz." cümlesine tam uygun davranmış oluruz..

Bazı özellikler şöyle :

gt - daha yüksek
gte - eşit veya daha yüksek
lt - daha düşük
lte - eşit veya daha düşük

Daha ayrıntılı bilgi için :

http://msdn.microsoft.com/en-us/library/ms537512.aspx
EsmerOzcan
kullanıcı
kullanıcı

İleti: 101
Kayıt: 27 Tem 2008 02:35
Konum: Nürnberg
İsim: Özcan Akbulut
HTML: Çok iyi
CSS: Çok iyi
PHP: Çok iyi
phpBB3: Çok iyi
Sürüm: phpBB 3.1.1

Re: internet explorer 6 kullananları uyarmak

İleti standartt 30 Haz 2009 00:50

gayet açıklayıcı olmuş. teşekkürler.
standartt
kullanıcı
kullanıcı

İleti: 132
Kayıt: 16 Oca 2009 01:27
Konum: Çorum
İsim: Rıfat ÜÇÜNCÜ
HTML: İyi
CSS: Başlangıç
PHP: Başlangıç
phpBB3: Orta
Sürüm: phpBB3 3.0.7 PL1


Kod Parçacıkları


Kimler çevrimiçi

Bu forumu görüntüleyenler: Kayıtlı kullanıcı yok ve 2 misafir

cron